Fatal error: Maximum execution time of 600 seconds exceeded

Read 9334 times
My stats havent been updating for the last few days. Im getting the the following error :

Fatal error: Maximum execution time of 600 seconds exceeded in /home/centovacast/system/servers/IceCast/class_ServerIceCast.php on line 0

When executing :

sudo -u centovacast /home/centovacast/system/runascc/runascc exec ccmanage processlogs all

Ive tried manually setting the php.ini :

max_execution_time = 3000
and
set_time_limit = 3000

But it doesn't seem to make a difference. I can't seem to find the value of 600 seconds anywhere in my php settings.

Is the timeout hard coded to 600 in the php script itself ?
My stats havent been updating for the last few days. Im getting the the following error :

Fatal error: Maximum execution time of 600 seconds exceeded in /home/centovacast/system/servers/IceCast/class_ServerIceCast.php on line 0

When executing :

sudo -u centovacast /home/centovacast/system/runascc/runascc exec ccmanage processlogs all

Ive tried manually setting the php.ini :

max_execution_time = 3000
and
set_time_limit = 3000

But it doesn't seem to make a difference. I can't seem to find the value of 600 seconds anywhere in my php settings.

Is the timeout hard coded to 600 in the php script itself ?

The most probable reason is that you have multiple copies of PHP installed on your system, your webserver uses one and your CLI uses another, and they both use different copies of the PHP config.
Thanks for the reply Steve.

Yeah im aware of the CLI / Apache 2 versions of php.ini and have checked them both and neither mention the 600 second timeout or take on my max_execution_time = 3000 / set_time_limit = 3000 settings.

I have also checked that i am only running 1 version of php (PHP 5.2.6-1+lenny13 with Suhosin-Patch 0.9.6.2). I presume though that runascc will be using the cli version ? Its hard to tell with everything being ionCube encoded. This is why i asked about the php timeout being hard coded in the script ? I know this is possible but couldn't tell if it was the case ?
Try creating a phpinfo file, that might help you pinpoint the problem
Thanks for the reply Steve.

Yeah im aware of the CLI / Apache 2 versions of php.ini and have checked them both and neither mention the 600 second timeout or take on my max_execution_time = 3000 / set_time_limit = 3000 settings.

I have also checked that i am only running 1 version of php (PHP 5.2.6-1+lenny13 with Suhosin-Patch 0.9.6.2). I presume though that runascc will be using the cli version ? Its hard to tell with everything being ionCube encoded. This is why i asked about the php timeout being hard coded in the script ? I know this is possible but couldn't tell if it was the case ?
Did you fixed this ? im facinng the same issue !