issue with liquidsoap on new ubuntu machine

Read 1374 times
Looks like I can't install liquidsoap with CC. This is a brand new fresh Ubuntu 22.04 LTS installation. It looks like the centovacast installer wants to install liquidsoap 1.4.0, but there are known bugs (https://github.com/savonet/liquidsoap/issues/1095).

Need at least 1.4.1-2. But I have no idea how to work around this..



# /usr/local/centovacast/sbin/update --add liquidsoap

Checking Centova Cast Common Files ...

Not updated, skipping                                                                                                               

Checking Liquidsoap ...

Downloading Liquidsoap ...                                                                                                         
Verifying archive integrity ...                                                                                                     
Unpacking archive ...

Installing Liquidsoap ...

Installing opam and dependencies...
opam 2.0.5 already installed, skipping
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
bubblewrap is already the newest version (0.6.1-1).
bzip2 is already the newest version (1.0.8-5build1).
g++ is already the newest version (4:11.2.0-1ubuntu1).
gcc is already the newest version (4:11.2.0-1ubuntu1).
m4 is already the newest version (1.4.18-5ubuntu2).
make is already the newest version (4.3-4.1build1).
patch is already the newest version (2.7.6-7build2).
ca-certificates is already the newest version (20230311ubuntu0.22.04.1).
file is already the newest version (1:5.41-3ubuntu0.1).
gzip is already the newest version (1.10-4ubuntu4.1).
tar is already the newest version (1.34+dfsg-1ubuntu0.1.22.04.2).
unzip is already the newest version (6.0-26ubuntu3.2).
0 upgraded, 0 newly installed, 0 to remove and 87 not upgraded.
Setting up ocaml compiler toolchain ...

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.


<><> Updating package repositories ><><><><><><><><><><><><><><><><><><><><><><>
[default] no changes from https://opam.ocaml.org
default (at https://opam.ocaml.org):
    [WARNING] opam is out-of-date. Please consider updating it (https://opam.ocaml.org/doc/Install.html)

O caml, my caml!
[NOTE] Package opam-depext is already installed (current version is 1.2.1-1).
Installing OS package dependencies ...
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
debianutils is already the newest version (5.5-1ubuntu2).
libmp3lame-dev is already the newest version (3.100-3build2).
libogg-dev is already the newest version (1.3.5-0ubuntu3).
libsamplerate0-dev is already the newest version (0.2.2-1build1).
libtag1-dev is already the newest version (1.11.1+dfsg.1-3ubuntu3).
libvorbis-dev is already the newest version (1.3.7-1build2).
pkg-config is already the newest version (0.29.2-1ubuntu3).
ladspa-sdk is already the newest version (1.17-1).
libmad0-dev is already the newest version (0.15.1b-10ubuntu1).
libfdk-aac-dev is already the newest version (2.0.2-1).
libflac-dev is already the newest version (1.3.3-2ubuntu0.2).
libmagic-dev is already the newest version (1:5.41-3ubuntu0.1).
libpcre3-dev is already the newest version (2:8.39-13ubuntu0.22.04.1).
zlib1g-dev is already the newest version (1:1.2.11.dfsg-2ubuntu9.2).
0 upgraded, 0 newly installed, 0 to remove and 87 not upgraded.
Building Liquidsoap ...
[NOTE] Package fdkaac is already installed (current version is 0.3.3).
[NOTE] Package magic is already installed (current version is 0.7.3).
[NOTE] Package ladspa is already installed (current version is 0.1.5).
[NOTE] Package flac is already installed (current version is 0.1.7).
[NOTE] Package samplerate is already installed (current version is 0.1.6).
[NOTE] Package cry is already installed (current version is 0.6.7).
[NOTE] Package vorbis is already installed (current version is 0.7.1).
[NOTE] Package lame is already installed (current version is 0.3.7).
[NOTE] Package mad is already installed (current version is 0.4.5).
[NOTE] Package taglib is already installed (current version is 0.3.10).
The following actions will be performed:
  ∗ install liquidsoap 1.4.0

<><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[liquidsoap.1.4.0] found in cache

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[ERROR] The installation of liquidsoap failed at "make install".

#=== ERROR while installing liquidsoap.1.4.0 ==================================#
# context     2.0.5 | linux/x86_64 | ocaml-base-compiler.4.08.0 | https://opam.ocaml.org#795f80f1
# path        ~/.opam/4.08.0/.opam-switch/build/liquidsoap.1.4.0
# command     ~/.opam/opam-init/hooks/sandbox.sh install make install
# exit-code   2
# env-file    ~/.opam/log/liquidsoap-114306-d2d111.env
# output-file ~/.opam/log/liquidsoap-114306-d2d111.out
### output ###
# [...]
# /usr/bin/install -c scripts/extract-replaygain /usr/local/centovacast/.opam/4.08.0/lib/liquidsoap/share/liquidsoap/1.4.0/bin
# find libs | grep '\.liq$' | while read l; do \
#   /usr/bin/install -c -m 644 $l /usr/local/centovacast/.opam/4.08.0/lib/liquidsoap/share/liquidsoap/1.4.0/libs ; \
# done
# /usr/bin/install -c -d /usr/local/centovacast/.opam/4.08.0/lib/liquidsoap/etc/liquidsoap
# /usr/bin/install -c -m 644 examples/radio.liq /usr/local/centovacast/.opam/4.08.0/lib/liquidsoap/etc/liquidsoap/radio.liq.example
# /usr/bin/install -c -d /usr/local/centovacast/.opam/4.08.0/lib/liquidsoap/etc/logrotate.d
# /usr/bin/install -c -m 644 scripts/liquidsoap.logrotate /usr/local/centovacast/.opam/4.08.0/lib/liquidsoap/etc/logrotate.d/liquidsoap
# /usr/bin/install -c -d /usr/share/bash-completion/completions
# /usr/bin/install -c -m 644 scripts/bash-completion /usr/share/bash-completion/completions/liquidsoap
# /usr/bin/install: cannot remove '/usr/share/bash-completion/completions/liquidsoap': Read-only file system
# make: *** [Makefile:85: install-local] Error 1



<><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
┌─ The following actions failed
│ ∗ install liquidsoap 1.4.0
└─
╶─ No changes have been performed

<><> liquidsoap.1.4.0 troubleshooting <><><><><><><><><><><><><><><><><><><><><>
=> We're sorry that your liquidsoap install failed. Check out our installation
   instructions at: https://www.liquidsoap.info/doc-1.4.0/install.html#opam
   for more information.
! Error: Failed to build Liquidsoap
! Error: Installation failed
Liquidsoap installation failed
! Error: Installer exited with error, aborting