unmet dependencies[solved]

Read 98 times
I'm having an issue with g++ and libc6
Ubuntu 20.04
Apache2, Mariadb, VSftp and phpMyAdmin are also installed before CentovaCast
Worked flawlessly until NIC failure and I did a fresh OS install thinking I was backed I'd be OK.
Once the server was back online and setup as a LAMP servers I started the CC install. (see results below)

== Centova Cast Installation ==========================================

Installing package dependencies ...
grep: ./etc/lsb-release: No such file or directory
Reading package lists... Done
Building dependency tree       
Reading state information... Done
debianutils is already the newest version (4.9.1).
debianutils set to manually installed.
findutils is already the newest version (4.7.0-1ubuntu1).
grep is already the newest version (3.4-1).
gzip is already the newest version (1.10-0ubuntu4).
rsync is already the newest version (3.1.3-8).
rsync set to manually installed.
sed is already the newest version (4.7-1).
sed set to manually installed.
wget is already the newest version (1.20.3-1ubuntu1).
wget set to manually installed.
mariadb-server is already the newest version (1:10.3.22-1ubuntu1).
tar is already the newest version (1.30+dfsg-7ubuntu0.20.04.1).
tar set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 build-essential : Depends: libc6-dev but it is not going to be installed or
                            libc-dev
                   Depends: g++ (>= 4:9.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Error: Centova Cast installer: apt-get exited with an error, aborting

I found 1 bug post from 2014 that didn't provide a solution
I found a lot of examples for correcting the error at digitalocean, linux, askubuntu and others and still getting an install error
if I find the solution I'll share

Last Edit: January 12, 2022, 07:08:41 am by 440music
Tommy TBones
Owner
440MUSIC.COM
Internet Radio & Music Store
The Granddaddy of Internet Radio for
Unknown, Unsigned and Indie Music
I found this and completed the install
aptitude -f install build-essential
Tommy TBones
Owner
440MUSIC.COM
Internet Radio & Music Store
The Granddaddy of Internet Radio for
Unknown, Unsigned and Indie Music