update error liquidsoap-1.3.3

Read 1809 times
 make[3]: Leaving directory `/usr/local/src/liquidsoap/liquidsoap-1.3.3-full/liquidsoap-1.3.3/src'
      make[3]: Entering directory `/usr/local/src/liquidsoap/liquidsoap-1.3.3-full/liquidsoap-1.3.3/src'
      OCAMLOPT -c shutdown.ml
      OCAMLOPT -c tools/stdlib.ml
      OCAMLOPT -c tools/doc.ml
      OCAMLOPT -c tools/utils.ml
      File "_none_", line 1:
      Warning 58: no cmx file was found in path for module Pcre, and its interface was not compiled with -opaque
      OCAMLOPT -c tools/plug.ml
      OCAMLOPT -c tools/rqueue.mli
      OCAMLOPT -c tools/rqueue.ml
      OCAMLOPT -c tools/wav_aiff.mli
      OCAMLOPT -c tools/wav_aiff.ml
      OCAMLOPT -c tools/tutils.mli
      OCAMLOPT -c tools/tutils.ml
      File "_none_", line 1:
      Warning 58: no cmx file was found in path for module Pcre, and its interface was not compiled with -opaque
      OCAMLOPT -c tools/JSON.mli
      OCAMLOPT -c tools/JSON.ml
      OCAMLOPT -c tools/file_watcher.ml
      OCAMLOPT -c tools/file_watcher_mtime.ml
      OCAMLOPT -c configure.mli
      OCAMLOPT -c configure.ml
      File "configure.ml", line 1:
      Error: /usr/lib64/ocaml/magic/magic.cmi
      is not a compiled interface for this version of OCaml.
      It seems to be for an older version of OCaml.
      make[3]: *** [configure.cmx] Error 2
      make[3]: Leaving directory `/usr/local/src/liquidsoap/liquidsoap-1.3.3-full/liquidsoap-1.3.3/src'
      make[2]: *** [all-auto-ocaml-prog] Error 2
      make[2]: Leaving directory `/usr/local/src/liquidsoap/liquidsoap-1.3.3-full/liquidsoap-1.3.3/src'
      make[1]: Leaving directory `/usr/local/src/liquidsoap/liquidsoap-1.3.3-full/liquidsoap-1.3.3'
      make[1]: *** [all-subdirs] Error 2
      make: *** [all] Error 1
! Error: Failed to build liquidsoap-1.3.3-full.tar.gz
! Error: Build failed
What operating system are you using?
What operating system are you using?

hi, my system is CentOS Linux release 7.5.1804 (Core)
what can i do, reinstall centovacast ?
Same here!

CentOS Linux release 7.5.1804 (Core)


      Error: /usr/lib64/ocaml/magic/magic.cmi
      is not a compiled interface for this version of OCaml.
      It seems to be for an older version of OCaml.
      make[3]: *** [configure.cmx] Error 2
      make[3]: Leaving directory `/usr/local/src/liquidsoap/liquidsoap-1.3.3-full/liquidsoap-1.3.3/src'
      make[2]: *** [all-auto-ocaml-prog] Error 2
      make[2]: Leaving directory `/usr/local/src/liquidsoap/liquidsoap-1.3.3-full/liquidsoap-1.3.3/src'
      make[1]: *** [all-subdirs] Error 2
      make[1]: Leaving directory `/usr/local/src/liquidsoap/liquidsoap-1.3.3-full/liquidsoap-1.3.3'
      make: *** [all] Error 1
! Error: Failed to build liquidsoap-1.3.3-full.tar.gz
! Error: Build failed
Installer exited with error, aborting
We had the same problem on trying to update, identical errors as above. 
very nice support here   :-\
Same here, after being sent some troubleshooting steps, the build completed, but liquidsoap is now failing to work at all...

I would avoid updating for a while until this is sorted.
Galaxy Web Solutions Ltd Est. 2004
Shoutcast/Icecast Hosting + Shoutcast/Icecast Reseller Solutions
Transcoding, GeoLocking, Flash Streaming, Mobile Streaming & more
GalaxyWebSolutions.com | 0800 61 24689 | 01454 620 217
I've not been able to update liquidsoap this is the error I get following the install documents:
[root@radio1 liquidsoap]# ./bootstrap
which: no gsed in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
Liquidsoap directory seems empty. I assume that submodules were not downloaded. Hold on, I'm doing it for you!
which: no gsed in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
make[1]: Entering directory `/usr/local/centovacast/liquidsoap/liquidsoap'
git fetch
git branch --set-upstream-to=origin/master master
error: unknown option `set-upstream-to=origin/master'
usage: git branch [options] [-r | -a] [--merged | --no-merged]
   or: git branch [options] [-l] [-f] <branchname> [<start-point>]
   or: git branch [options] [-r] (-d | -D) <branchname>
   or: git branch [options] (-m | -M) [<oldbranch>] <newbranch>

Generic options
    -v, --verbose         be verbose
    -t, --track           set up tracking mode (see git-pull(1))
    --set-upstream        change upstream info
    --color[=<when>]      use colored output
    -r                    act on remote-tracking branches
    --contains <commit>   print only branches that contain the commit
    --abbrev[=<n>]        use <n> digits to display SHA-1s

Specific git-branch actions:
    -a                    list both remote-tracking and local branches
    -d                    delete fully merged branch
    -D                    delete branch (even if not merged)
    -m                    move/rename a branch and its reflog
    -M                    move/rename a branch, even if target exists
    -l                    create the branch's reflog
    -f, --force           force creation (when already exists)
    --no-merged <commit>  print only not merged branches
    --merged <commit>     print only merged branches

make[1]: *** [init] Error 129
make[1]: Leaving directory `/usr/local/centovacast/liquidsoap/liquidsoap'
make: *** [check-init] Error 2

I can not connect with the administration web or any of the radio stations on port 2199 or 8000 - 8040. They all stopped working about 5 days ago and I've not been able to resolve the problem.
Tommy TBones
Owner
440MUSIC.COM
Internet Radio & Music Store
The Granddaddy of Internet Radio for
Unknown, Unsigned and Indie Music
Same here, after being sent some troubleshooting steps, the build completed, but liquidsoap is now failing to work at all...

I would avoid updating for a while until this is sorted.

Also getting this error when upgrading - Can you share the steps you used?
This type of error message typical indicates, that some of the older Ocaml packages in your system could not be automatically upgraded for some reason. This is a common occurrence when using Ocaml in general.

To perform a manual cleanup of older Ocaml packages, I used the following commands.

ocamlfind remove pcre
ocamlfind remove magic
ocamlfind remove camomile
ocamlfind remove yojson
mv /usr/lib64/ocaml/yojson /tmp
mv /usr/lib64/ocaml/magic /tmp

rpm -e $(rpm -qa | grep ocaml)
yum-complete-transaction
yum clean all

Again this worked for me, but may not work for you. Please consult with your System Admin before blindly copy and pasting something you find on the internet.
Stream101 || Affordable Media Solutions
http://www.stream101.com | 877-240-7767
We have exact the same problem. Our webmaster already perform a manual cleanup of older Ocaml packages several times like recommended from the support but with no success. The support claims that this could be an issue with our system's package manager configuration is broken, or that we are using an unsupported Linux distribution but this isn't the case as we are using a normal "Debian GNU/Linux 8.11 (jessie)" and several using are reporting the same about this problem. Installing "Liquidsoap 1.1.1" from the Linux server also works without problems, so it's obviously not an issue with the "APT". Furthermore he installed the packet "ocaml" without problems, even with APT (V 4.01.0-5).

Finally, we were recommended to use a professional installation service, which costs just $ 70 but somehow I don't accept that because it seems to be an obvious bug in the installations cript and only seems to be a smaller issue to fix. >:(

Is there any other solution we can do?
Has anyone found a fix for this issue yet?
Meanwhile, I got it up and running. I do not even know exactly how but I guess that it has something to do with the installation of a wrong OPAM package, maybe even through the Centova Cast installation script.

But after deleting the two OPAM folders in the "root"-folder and then downloading the current packages via Debian command, as suggested on the OPAM website, the installation worked flawlessly via its update feature.

apt-get install opam

After that I did the installation of Liquidsoap again via the installation script, this time without error messages.

/usr/local/centovacast/sbin/update --add liquidsoap

After that, I was able to use Shoutcast 2 with Liquidsoap as Auto DJ.

So it seems that some users have to install OPAM via distribution's package system instead with the automatic OPAM script which was also not working for me.

Maybe this info page will also help other users who have similar problems:
https://opam.ocaml.org/doc/Install.html

Last Edit: February 19, 2019, 12:15:40 am by Radio_PARALAX