Problem with ports on sc_trans2

Read 4910 times
Hi guys,
Yesterday i transferred my Centova v2 to v3 and it was a total success.

The problem im having is when i create ShoutCast2 with Sc_trans2 Account. When i start the server its okay but when i try to start the source it does not start. I checked the logs and i found the following likes:

2013-03-22 14:40:01 E msg:[MAIN] Error opening port 8014 because Could not bind to :8014 because Address already in use 2013-03-22 14:40:01 E msg:API server startup error. Could not bind to :8015 because Address already in use

Those ports are busy by other accounts so there is no way to set them free. I think its trying to bind not on one interface but on the all interfaces which is even worst.

Is there any way to change the ports, they must be a at,est after port 8050
Anyone ?
Are your old streams still running in v2 ?
im not releasing v2 because of this problem ..
same problem !
Anyone got solution ?
Yes sometimes ports do not work, usually ports that were once in use, I think when a account gets deleted the port# seems gets stuck in the database somewhere, changing the users port # is the only solution I have found, it has been like this for months

just found a account with a port problem http://prntscr.com/ycgci -- this was a auto created account, the port 8013 is not in use by any other clients on this server   
Last Edit: March 29, 2013, 06:09:49 am by My Auto DJ
My Auto DJ
Orlando, FL USA
Quality SHOUTcast Hosting http://myautodj.com
SHOUTcast Widgets http://shoutcastwidgets.com
Yes sometimes ports do not work, usually ports that were once in use, I think when a account gets deleted the port# seems gets stuck in the database somewhere, changing the users port # is the only solution I have found, it has been like this for months
I very much doubt that this is related to sylar's issue, given that he explicitly stated:

Those ports are busy by other accounts so there is no way to set them free.

Clearly if the port number is in use by another stream, it's not been deleted. :)

Those ports are busy by other accounts so there is no way to set them free.
Are you saying that Centova Cast is reusing ports that *CENTOVA CAST ITSELF* has already allocated to other Centova Cast accounts on the same IP address?  If so, something is very wrong there and I'd recommend opening a ticket with the helpdesk so we can investigate further.

I think its trying to bind not on one interface but on the all interfaces which is even worst.
No, definitely not.  It binds to the IP address assigned to the account in the account configuration.

Is there any way to change the ports, they must be a at,est after port 8050
Yes, you can change the port range under Settings -> Defaults -> Port range for new accounts.
Hello,
The issue that has been brought to the attention to this forum is very real and it would be nice to know how to fix it.
It happens after re-installations that a stream cannot work because the PORT is seen as already in use, while it is clearly free.
It looks like sometime, some ports in exceptional cases remains written in a list as in use, while it is not.
Using a different port is not always an option, especially if the stream is registered worldwide with that port, and as you may know Apple does not allow changes to the existing teams...this means: wrong port, you are out from iTunes.
How can this problem be fixed, please?
Thank you.
Regards