Error after Linux Control Daemon Installation

Read 4949 times
The Linux Control Daemon Installation finished without error, but on the master server, it shows:
Code: [Select]
Socket error while receiving command responseunder OS in the status page.

All that's showing in the log for the relay server on the master is:
Code: [Select]
We apologize for the inconvenience, but an internal error has occurred.  Please try again later.

Details: Unhandled exception: Socket error while receiving command response in /usr/local/centovacast/system/class_RPCDaemonClient.php:

#0 /usr/local/centovacast/system/class_RPCDaemonClient.php(1001): RPCDaemonClient::gets()
#1 /usr/local/centovacast/system/class_RPCDaemonClient.php(1039): RPCDaemonClient->gets()
#2 /usr/local/centovacast/system/class_RPCDaemonClient.php(1090): RPCDaemonClient->get_response()
#3 /usr/local/centovacast/system/class_RPCDaemonClient.php(949): RPCDaemonClient->send()
#4 /usr/local/centovacast/system/class_RPCDaemonClient.php(1068): RPCDaemonClient->authenticate()
#5 /usr/local/centovacast/system/class_RPCDaemonClient.php(1009): RPCDaemonClient->send('cmd ls '/usr/lo...')
#6 /usr/local/centovacast/system/class_RPCDaemonClient.php(220): RPCDaemonClient->command()
#7 /usr/local/centovacast/system/class_GenericDaemonClient.php(306): RPCDaemonClient->ls()
#8 /usr/local/centovacast/web/admin//rpc/class_RPClogmanager.php(223): GenericDaemonClient->dir()
#9 /usr/local/centovacast/web/admin//rpc/class_RPClogmanager.php(39): RPClogmanager->get_list()
#10 /usr/local/centovacast/web//rpc/class_RPCServer.php(192): RPClogmanager->api_get_folder_list('/hosts/2/')
#11 /usr/local/centovacast/web/class_RPCApplication.php(335): RPCServer->execute()
#12 /usr/local/centovacast/web/admin/rpc.php(20): RPCApplication->execute()
#13 {main}

I've verified that cc-web and cc-control are running on the relay, and when I issue a stop, the master shows:
Code: [Select]
Cluster host connection failure for xxx: Connection refused (111)as I'd expect.

Initially it had this error:
Code: [Select]
Cluster host connection failure for xxxxx: No route to host (113)but opening port 2198 in both servers solved that one.

Also, a
Code: [Select]
netstat -an |grep 2198 shows 0.0.0.0:2198 which tells me the v2 instance running is causing a conflict. It would seem the statement that V2 and V3 can co-exist on the same server doesn't apply to relay servers?
I'll be waiting until later when the load drops so I can shut it down without upsetting as many listeners, to see if that's the problem.
Turns out the netstat response was referring to the V3 install, so killing all sc_serv didn't make a difference.

But checking on the license status I noticed that only the host name was listed with the IP address, instead of the FQDN.  Checking the /etc/hosts file, it turns out I had the entry: IP host FQDN, instead of IP FQDN host.
After correcting that, I uninstalled, re-issued the license, and re-installed (but this time using the --deps option I found in the remarks of the install.sh file - which I didn't see in the installation manual).

On the control server, there was no longer the error, but under OS it did say something like: 'Information Unavailable,' though the uptime, load, etc was displayed.
Not sure if it just took time, or it was some of the nudging I was trying, but the next time I went back, the OS was displaying as well.

Now, both servers show in Hosts, Status, and Logs, but that's it.  I have yet to find out how to manage the remote.
I tried creating a new user, but the remote server isn't included as an option.

I haven't searched the forum for this yet, I wanted to get the above posted, so I'll start another thread if I don't find anything.  But hints and suggestions are welcome.
Quote
(but this time using the --deps option I found in the remarks of the install.sh file - which I didn't see in the installation manual)
Correction, I had seen this in the advanced section, just forgot.