Is Centova v3.2.14 compatible with Shoutcast 2.5?

Read 3023 times
Hello friends,

I am currently looking to update my Centova Cast panel but I wasn't sure if Shoutcast v2.5 is currently supported in the latest version. Me personally, I am not a huge fan of the new sc 2.6 freemium version. Would I still be able to keep my current version of Shoutcast and not be forced to update to 2.6? thanks
yes works great