Database problem after migration

Read 3811 times
Hello,

I've used this information:
https://centova.com/en/faq/cast3/information/migrating_a_centova_cast_installation_to_another_server

At the new server, i cannot create a new user and get this error:

Code: [Select]
SQL Error: Could not execute query in /usr/local/centovacast/system/class_AccountControl.php:135
Query: INSERT INTO accounts (`ignoremeta`,`username`,`hostname`,`ipaddress`,`port`,`secureport`,`maxclients`,`transferlimit`,`diskquota`,`noxferlimit`,`nodiskquota`,`allowproxy`,`allowtls`,`rawconfig`,`mountlimit`,`quotaexceed`,`xferexceed`,`channels`,`samplerate`,`crossfade`,`maxbitrate`,`genre`,`recenttracks`,`timezone`,`charset`,`locale`,`url`,`useserver`,`nextsongdebug`,`webplayer`,`requestprobability`,`requestdelay`,`autoqueuerequests`,`emailunknownrequests`,`title`,`email`,`usesource`,`royaltymode`,`sharemedia`,`shareplaylists`,`usecontentfrom`,`autorebuildlist`,`randomplaylist`,`usestartpage`,`allowrequests`,`allowondemand`,`allowrecent`,`allowgmaps`,`organization`,`songlengthlimit`,`tlsmethod`,`rpchostid`,`adspriority`,`extraports`,`customvalues`,`status`,`servertype`,`parentresellerid`,`password`,`expectedstate`,`secret`,`reseller`) VALUES ('','xxxxxxxxx','example.com','207.180.230.141','8010','0','10','1500','1000','0','0','1','1','0','0','auto','auto','2','44100','0','128','nicht angegeben','5','127','ISO-8859-1','','http://localhost/','1','0','centova','50','30','1','1','Mein Stream','juergen@home.at','2','0','0','0','0','1','1','1','1','1','1','1','','5400','custom','1','custom,embedded,folder,itunes,!lastfm,!amazon','','','enabled','IceCast','0','$2y$10$Ffl/8N5lS5rX3yLUPaabn.b97O7sCZ4HtoTb93TeIqQeqXRYBAXXO','down',"adcee23b23334f7c08b816748eb4860f",0)
Error: Field 'statuscache' doesn't have a default value
Call: $SQL->insert_query()

My old server uses Centova 3.2.12 (update is not possible -> license)
My new server uses Centova 3.2.15 (active leased license)

I've tried:

Code: [Select]
/usr/local/centovacast/sbin/update
and

Code: [Select]
/usr/local/centovacast/sbin/update --force
but the problem still exists.

What can i do now?

Best regards,
Jürgen
The support wrote me the following (shortend):

Quote from: Support
This typically indicates that your database server is trying to enforce STRICT_TRANS_TABLES mode by default. [...]

To bypass this issue edit /usr/local/centovacast/etc/centovacast.conf and add:

Code: [Select]
SESSION_SQL_MODE=NO_ENGINE_SUBSTITUTION
at the end of this file. Finally restart Centova Cast "/usr/local/centovacast/centovacast restart", and the error message should go away.

It looks good and the error is solved... ;) GREAT!