Trouble streaming Opus

Read 97 times
I would like to stream Opus but I am having trouble getting it going.  On the test mount point I am able to stream a folder of 128kbps CBR MP3 files to Icecast V2 using MP3 or AAC without issue.

When I switch to the encoder to Opus the system says the stream has started but there is no audio and no recent tracks.  I look in liquidsoap's source.log and find messages like this

2020/02/05 12:23:17 [decoder:4] Trying method "META" for "/usr/local/centovacast/var/vhosts/blue/var/spool/media/10,000 Maniacs - MTV Unplugged - 12 - Because the Night.mp3"...

It looks like it's trying to figure out what format the source file is and failing.  These same files work for MP3 and AAC streaming but not Opus.

Also in source.log is this line
2020/02/05 15:30:04 [main:3] Using: graphics=[distributed with Ocaml] pcre=7.0.2 dtools=0.3.1 duppy=0.5.1 duppy.syntax=0.5.1 cry=0.2.2 mm=0.2.1 xmlplaylist=0.1.3 lastfm=0.3.0 ogg=0.4.5 vorbis=0.6.1 opus=0.1.0 speex=0.2.0 mad=0.4.4 flac=0.1.1 flac.ogg=0.1.1 dynlink=[distributed with Ocaml] lame=0.3.2 shine=0.1.1 gstreamer=0.2.0 frei0r=0.1.0 voaacenc=0.1.0 theora=0.3.0 schroedinger=0.1.0 gavl=0.1.5 bjack=0.1.4 alsa=0.2.1 ao=0.2.0 samplerate=0.1.2 taglib=0.3.1 magic=0.7.3 camomile=0.8.4 inotify=1.0 faad=0.3.2 soundtouch=0.1.7 portaudio=0.2.0 pulseaudio=0.1.2 ladspa=0.1.4 dssi=0.1.1 sdl=0.9.1 camlimages=4.0.0 lo=0.1.0 yojson=1.1.7 gd=1.0a5

which to me looks like it detects opus.

Unlike the previous posters I don't have the message indicated the Opus encoder is not found.  I am getting these decoding errors instead.

I tried that solution mentioned earlier about installing opus-devel via apt-get but I don't have the opus-devel package in my repository.

I tried using opam to install opus but as the centovacast user it doesn't have permission to write to the centova main folder.  As a non-centova user opam wants me to install some additional software which isn't mentioned in the post.

I installed libopus, liquidsoap-plugin-opus, and opus-tools via apt-get and that doesn't fix it. I do see the file opus.cmxs in the /usr/lib/liquidsoap/1.1.1/plugins/ folder.

Calling /usr/local/icecast/bin/icecast -v results in the system telling me that Icecast 2.4.2 is installed.

I am running Linux kernel 3.13 on Ubuntu 14.04 LTS.   I am running Centova 3.2.7.   What I need first is to get the system going; to get Opus streaming to the assigned Icecast V2 mount point.