cc-appserver not running

Read 1023 times
From the start:
Centos 6.9
Centovacast 3
Dedicated Server

cc-appserver manually stopped is the response when I run centovacast check
if I run centovacast start-app I get the response cc-appserver already running
if I killall cc-appserver  I still get cc-appserver manually stopped
when I do a restart centovacasat restart and check I still get cc-appserver manually stopped

I found only 1 post addressing this subject and the last line was to force an upgrade and I've recently ran out of time for the free upgrade.

I can not log-in to the admin panel or reach any of the 10 radio stations
Things were working until I added extra space for the var directory
I can run my backup server for a few days but need to fix this ASAP

Thanks
Tommy TBones
Owner
440MUSIC.COM
Internet Radio & Music Store
The Granddaddy of Internet Radio for
Unknown, Unsigned and Indie Music
The command that I use (on CenTOS 6.9) is:
 #service centovacast status

This shows the current state of all of the sub-processes:
cc-control: running (pid 2236)
cc-appserver: running (pid 2263)
cc-comet: running (pid 2245)
cc-web: running (pid 5336)
cc-ftpd: running (pid 2268)
cc-imaged: running (pid 2276)

What do you get when you run the above command ?

We have written a PHP program that we run with a CRON job every 5 minutes to check the status of all of the sub-procrsses.  If any of them are stopped, it issues a command:
 #service centovacast restart
the results are:
cc-control: running (pid 4468)
cc-appserver: manually stopped
cc-comet: running (pid 4477)
cc-web: running (pid 22815)
cc-ftpd: running (pid 4493)
cc-imaged: running (pid 4502)

when I use top I see cc-appserver is running and I've tried to kill the process and the results don't change
Last Edit: October 28, 2018, 04:25:19 pm by 440music
Tommy TBones
Owner
440MUSIC.COM
Internet Radio & Music Store
The Granddaddy of Internet Radio for
Unknown, Unsigned and Indie Music
OK I got cc-appserver running again and this is what I did
to get pid run
 ps aux | grep cc-appserver
root     30824  0.0  0.0 122992  3412 ?        Ss   12:42   0:00 cc-appserver: master process (/usr/local/centovacast/etc/cc-appserver.conf)
10001    30825  0.0  0.0 123688  6804 ?        S    12:42   0:00 cc-appserver: pool webintf                                                 
10001    30826  0.0  0.0 123672  6788 ?        S    12:42   0:00 cc-appserver: pool webintf                                                 
10001    30827  0.0  0.0 123928  7012 ?        S    12:42   0:00 cc-appserver: pool webintf                                                 
10001    30828  0.0  0.0 123676  6796 ?        S    12:42   0:00 cc-appserver: pool webintf                                                 
root     31117  0.0  0.0 103320   908 pts/0    S+   12:49   0:00 grep cc-appserver
and the kill the 5 processes
then ran top again and saw cc-web and cc-comet and did
 ps aux | grep cc-web
 ps aux | grep cc-comet
and killed the process then I restarted centovacast in /usr/local/centovacast
./centovacast status and saw that cc-appserver not running
./centovacast restart and cc=appserver was running as normal
I still can not connect to web panel or stations I will restart server to see if everything starts

after reboot cc-appserver is running but I still con not connect to the admin panel or any of the 10 stations
Last Edit: November 01, 2018, 10:33:43 am by 440music
Tommy TBones
Owner
440MUSIC.COM
Internet Radio & Music Store
The Granddaddy of Internet Radio for
Unknown, Unsigned and Indie Music