Numerous Issues - FTP, Recent Tracks and Web Audio Player (Hoping all related)

Read 315 times
Hi guys,

I just thought I'd send a message here just to see if anyone has been experiencing the same issues as me.
It really is quite frustrating and I have found support from my new Radio Host to not be very helpful...thus far anyway.

I've used Centova Cast with an older radio host before and I've never experienced these issues so I "suspect" it might be an issue with how the host stream was initially set up.

I thought maybe I could explain my issues here so a Centova Cast Support Expert could be like "This is your exact problem" and "this is what you/your host need to do".

Anyways, I'll start from the very top.

Server type:
ShoutCast2

AutoDJ type:
liquidsoap

After signing up to a 192k Shoutcast Webcaster Service a couple of days ago, I have had the following issues;

Issue 1: FTP - Cannot Login.

This is has me pulling my hair out because I have tried every possible combination of host addresses, ports, Encryptions, login types, etc etc
I am using Filezilla. The closest I appear to getting logged on is when I pass the user/password part of the login but then I get the following error:
Response:   421 Home directory not available - aborting
Error: Could not connect to server

This is the full Login sequence here;
Status:   Connection established, waiting for welcome message...
Response:   220-Welcome to cc-ftpd.
Response:   220-You are user number 1 of 50 allowed.
Response:   220-Local time is now 23:01. Server port: 21.
Response:   220-This is a private system - No anonymous login
Response:   220-IPv6 connections are also welcome on this server.
Response:   220 You will be disconnected after 15 minutes of inactivity.
Command:   AUTH TLS
Response:   500 This security scheme is not implemented
Command:   AUTH SSL
Response:   500 This security scheme is not implemented
Status:   Insecure server, it does not support FTP over TLS.
Command:   USER iutwajyp
Response:   331 User iutwajyp OK. Password required
Command:   PASS **********
Response:   421 Home directory not available - aborting
Error: Could not connect to server

The only way I can upload my music is via the Centova Cast File Manager which given I have over 550 artists and you can only upload as single files (not folders), it's a very tedious process at the moment :(

=========================

Issue 2: RECENT TRACKS Widget not working on my website

My RECENT TRACKS PLAYED is showing up on my website as "Unavailable"
I've entered the Widget script code as specified to do.
Under my Centova Cast it works ok on the GENERAL page, but have also noticed the album art isn't being displayed in the top right corner (grey image) - this is sitting hovering over the icons in the top right corner (See image centova-diff.png in my reply showing the noticeable difference between the old & new accounts of mine).
Also when I hover my mouse of the UNAVAILABLE it shows the following error message:
"Unable to access the account: Invalid Username or Password"

Issue 3: Web Player Widget not working

This is one of the first things I noticed when I first logged into my new account. After I had manually uploaded some music files & started a new autodj & playlists, I tried to hit play on the black web player in the very top right corner (next to the grey artwork picture) and clicking on the play button would do nothing. I thought, that's weird so I tried to play it on the Web Audio Player via 'Your stream start page' under quick links and the play button would turn green but no stream would play.
I suspect this webplayer widget won't work on my website too. I haven't tried.
The only stream I can get playing of my new station is via the audio player under the SHOUTcast Stream Status in the "Your streaming server index page".

There's probably other quirky stuff going on that I haven't discovered yet but like I said I'm hoping that a Centova Cast expert might be able to pin point what what be going on.
I keep thinking maybe when the login/password got automated by the host, it didn't set it up correctly. I have suggested to the host maybe they reset the user/password for me but haven't heard back on that yet.

I dunno...please help me. I'm at my wits end at the moment >_<
Last Edit: July 24, 2018, 09:06:39 pm by undiscoveredrockradio
centova-diff.png here

Old Account was Icecast btw.
Last Edit: July 24, 2018, 09:07:18 pm by undiscoveredrockradio