Icecast Error

Read 8355 times
Hi there,

I managed to install the Beta well the first time - then I wanted the Icecast package to be included. I ran into this error during the installation :


Installing IceCast ...

Downloading icecast ...
  > Download error details:                                                   
  > http://downloads.xiph.org/releases/icecast/icecast-2.3.2-0.src.rpm: No such file or directory
Failed to download icecast from official server, trying centova.com servers ...
  > Download error details:                                                   
  > http://www.centova.com/clientdist/icecast-2.3.2-0.src.rpm: No such file or directory
Unable to download icecast
Installer exited with error, aborting
Installer exited with error, aborting

If you could help, that would be highly appreciated.

Best,
Marc5000
Hi

I've also noticed, in the Centova Cast v2, there used to be a field to place the executable location for Icecast. Has this gone?

Best,
Marc5000
This means there's something wrong with your DNS resolver on your server and it's sending you to some other server.  Both of the URLs you quoted work fine (try them in a browser).
This is odd, because when I WGET that URL or WGET any other url (like I did for my own IceCast build) it works. Fine.

When I installed Centova Cast for the first time (fresh) I just ran the installer script with no additional packages, and it finished well - no errors. Perfect, the install took me 3 minutes, compared with 30 minutes with the last release!! Then I couldn't get IceCast working, so like a dummy I --force the install to re-install Centova with the Icecast packages.. I then received that error.

I did notice that my centova panel didn't work after that, so I restarted the centova process - and that worked fine. However, every time I ran the Centova install, again (forced), without the Icecast package.. it was always telling me that it couldn't download the packages... but I never asked it to!!!! Funny installer script..

Anyway, despite all that, I thought there was something extra in the installer script, so I deleted it - re downloaded it and then ran it again.. still, it was trying to fetch those RPM's from Icecast when I never told it to.

Never the less, I left it and started the Centova process again. I then used the command to add my own binary directory of Icecast - and now it works! Horray! Just make sure you turn it on in the Centova Panel! x_x

Marc5000
his is odd, because when I WGET that URL or WGET any other url (like I did for my own IceCast build) it works. Fine.
Bah, my mistake, I read the error message wrong -- it's saying "No such file or directory", not 404 not found.  I found the problem and the package has been updated with a fix.

Then I couldn't get IceCast working, so like a dummy I --force the install to re-install Centova with the Icecast packages.. I then received that error.
If you're interested the quickref guide explains how you can add packages (incl. IceCast) after-the-fact without reinstalling Centova Cast.

However, every time I ran the Centova install, again (forced), without the Icecast package.. it was always telling me that it couldn't download the packages... but I never asked it to!!!! Funny installer script..
Once you request the packages, they're added to your update list so any time you do an update (and reinstalling with --force is basically a full update) the installer will check them for updates.  If an update is available -- or if the package was never installed -- it'll try to install it again.

Best not to force a reinstallation over top of an existing one -- always rm -rf /usr/local/centovacast/ before doing a reinstallation to make sure you're getting a nice fresh start.