SHOUTcast Server v2.5.0.715 BUGGED

Read 3712 times
Dear Centova,

i've noticed that all the clients running the new SHOUTcast Server v2.5.0.715

experience a terrifying buffering. The old accounts that running the version 2.4.7 works perfectly.

I've been forced to back on all my server the version 2.4.7 .

Something has changed on the new 2.5.0.715 version ..and all the clients experienced really huge delay on start , buffering problem and so on.. using liquidsoap and even in live mode..

I've back all my servers to the sc_serv version 2.4.7 .. the 2.5 is not stable at all.. please verifiy for your next upgrade. Fortunately i got a backup of the previous version of the sc_serv cause on the shoutcast.com main site you can not download more the previous version... damn something is going really bad withShoutcast

I'm running debian 64 bits
Last Edit: July 26, 2016, 07:16:42 pm by hostingshoutcast
This is actually the first report of this kind, that I know of, at least. So I am inclined to think that it's something particular to your server that's triggering the problem with the latest Shoutcast version.
Hello AlexiuB,

I'm trying the latest free Centova version with Shoutcast v2.5.0.715 on a server with Centos 7 64 bit.
Respect to other server with Shoutcast v2.4.0.147 I'm experiencing some delay on start too. I tried to change the buffer value on Raw Configuration (and also I changed between fixed and adaptive buffer), but nothing changes. Maybe there is a little bug?

Best regards,
Massimo
The 2.5 release being mentioned afaik was released as a beta as such. However one thing to try is setting ratelimit=0 in the DNAS config which then disables a number of the advert related handling changes that were introduced into the 2.5 builds (i.e. if you're not using the DNAS+ / advert system then it's better to set that option to get back to a more 2.4.7-like behaviour).

Additionally, i believe the option I added (when I was involved with SC development) was called ratelimitwait which was a default of a few seconds (5 maybe) which allows that much of the stream to be sent to the listener un-restricted before the stuff I've mentioned above kicks in if that option is enabled. it accepts second values so is something else to try out. Tweaking that can help with connection times (along with the overall networking buffer as per the docs shipped with the DNAS).

Dunno if any of that will be helpful (considering how late I am to see this), otherwise probably going back to 2.4.7 is the better option (and if the fancy takes you, complaining to SC about such issues so whatever dev team there now is might just consider fixing things or not, heh.

-dro
setting ratelimit=0

where can i find that
Thank you, Dr0!
With ratelimit=0 I solved the problem! :)

@streampakket you have to add "ratelimit=0" in the 'Raw Configuration' (if enabled) under the 'Setting' menu for every account!