Copy To New Server

Read 4123 times
I know how to copy an entire Centovacast from one server to an new server.

However, I wanted to know if anybody knows an easy way to copy 1 user (with 20 gigs of songs) from a Centovacast 3.1.0 to a Centovacast 3.1.0 on a different server (different IP).

I have about 4 accounts to do this to.  I asked the user and, of course, he is giving me a rash of trouble, as all of his playlists will have to be re-created, and he refuses.

Just wondering.

Thanks !!
Hello Dennis,

This topic has been discussed many times, please make sure to search the forum before posting questions ;).

Your answer is here http://forums.centova.com/index.php?topic=1698.msg6520#msg6520


HTH

Thank you for your kinid help, but it didn't work ..

I tried:

/usr/local/centovacast/bin/ccmanage backup --username=c8022

and got this error message:

Result: ERROR Backup archive: Error creating archive: Seek error: Invalid argument
Just to give it a try... Try the following to see if it attempts to do the backup:

Code: [Select]
/usr/local/centovacast/bin/ccmanage backup --username=USERNAME  --nocontent

If it does go through with that, that means the problem you are having is to many music files, in which what you would have to do is tar the music files by themselves and then rsync the tar file over from one server to the other server...

After you restore the account on the new server, then untar the music in the correct area for that user, then run --updateall for that user to update the music into the account.
CrossFire-Hosting LLC.
Co-Owner
Thanks for the help ..

Yes, that did allow me to finish the backup ..

However, now I can't restore it .. trying:

/usr/local/centovacast/bin/ccmanage restore --filename=/downloads/webcentovacast.conf.20140507064353 --rpchostid=1 --username=c8022

and

/usr/local/centovacast/bin/ccmanage restore --filename=/downloads/webcentovacast.conf.20140507064353 --rpchostid=1 --username=c8022 --novalidate=0

and I get:
Result: ERROR Could not unpack backup file: Signature verification failed: Signature marker not found in /downloads/webcentovacast.conf.20140507064353

I think that is the error another user was getting.  His post(s) just end ... with no resolution.
--filename=/downloads/webcentovacast.conf.20140507064353

is this the file name that centova cast created for the users account?

"webcentovacast.conf.20140507064353"

That doesnt seem correct.  It should have saved the file as something like this:

/usr/local/centovacast/var/backups/vhosts/backup-username_bunchofnumbers.zip

Make sure you are transferring the correct file to the new server.


restore using:

Code: [Select]
/usr/local/centovacast/bin/ccmanage restore --filename=/usr/local/centovacast/var/backups/vhosts/NAMEOFBACKUPFILE.zip --rpchostid=1 --username=USERNAME --novalidate

Just be sure the file is in that folder when restoring.
Last Edit: September 04, 2014, 08:14:31 am by DJFire_CFR
CrossFire-Hosting LLC.
Co-Owner
Thanks .. I guess:
webcentovacast.conf.20140507064353

was hanging around from my past failed attempts.

Found the zip file and that worked.
Great.  :)
CrossFire-Hosting LLC.
Co-Owner