Installing LiquidSoap; Can't Build camomile

Read 6136 times
Has anyone else run into this? I'm running Scientific Linux 6.5 and Centova Cast 3.1.0.

Code: [Select]
# /usr/local/centovacast/sbin/update --add liquidsoap
...

Configuring camomile ...

checking for cppo... false
checking for grep that handles long lines and -e... /bin/grep
checking for fgrep... /bin/grep -F
checking for ocamlc... ocamlc
ocaml version is 3.11.2
ocaml library path is /usr/lib64/ocaml
checking for ocamlopt... ocamlopt
checking ocamlopt version... ok
checking for ocamlc.opt... ocamlc.opt
checking ocamlc.opt version... ok
checking for ocamlopt.opt... ocamlopt.opt
checking ocamlc.opt version... ok
checking for ocamldep... ocamldep
checking for ocamllex... ocamllex
checking for ocamllex.opt... ocamllex.opt
checking for ocamlyacc... ocamlyacc
checking for ocamlweb... true
checking for camlp4o... camlp4o
checking for ocamlfind... install-with-ocamlfind
checking for ocamldoc... ocamldoc
configure: creating ./config.status
config.status: creating Makefile
config.status: WARNING:  'Makefile.in' seems to ignore the --datarootdir setting
config.status: creating META

Building camomile ...

Makefile:547: .depend: No such file or directory
false -I internal -I public -I toolslib -I . -o camomileLibrary.mli camomileLibrary.mlip
make: *** [camomileLibrary.mli] Error 1
Make failed for camomile.tar.gz; aborting
Installer exited with error, aborting

Thank you,
Chris
I am receiving this exact same error in a fresh build of CentOS 7.  Did you ever find a solution?
Hi there,

I am bumping this thread because I am having the exact same issue as we speak =/
I got the same problem !!! Any solution ? 
I'm afraid there is no solution for unsupported Linux distributions.

For everyone running Centos or Debian, just open a ticket to our support department and we'll be happy to help.
Last Edit: September 25, 2017, 01:15:21 pm by Roger
I exactly have the same problem here.  Any solution? I have sent a ticket but I haven't receive a reply yet.
Thanks
./install.sh --icecast --icescc
and the problem is solved.
I tried adri's solution, but that does not work for me. I still get the same error;

Processing camomile.tar.gz ...


Autoconfiguring camomile ...

autoconf: error: no input file
Autoconf failed for camomile.tar.gz; aborting

I hope someone can help out.
Did some checking and found that the version of cppo used by the Centova installer is very, very old. They use cppo-0.9.4.tar.gz . The latest version 1.6.0 and can be found here: https://opam.ocaml.org/packages/cppo/

I have no idea whether it would be possible to use this newer version. Maybe the developers can have a look at it.

 
It worked for me. But I do not like centos, and now with debian I have a number of new problems. Issues with liquidsoap and ices.
I tried adri's solution, but that does not work for me. I still get the same error;

Processing camomile.tar.gz ...


Autoconfiguring camomile ...

autoconf: error: no input file
Autoconf failed for camomile.tar.gz; aborting

I hope someone can help out.

This is actually NOT the same issue at all, this one in particular is caused by a new release of camomile that introduced some changes to the build configuration.

Customers looking to build liquidsoap on their system, can manually download a copy of the compatible Camomile source at http://rd.centova.com/files/camomile-0.8.5.tar.gz , then replace the existing package under "/usr/local/src/liquidsoap/dlcompleted/".

For example:

cd /tmp
wget http://rd.centova.com/files/camomile-0.8.5.tar.gz
mv camomile-0.8.5.tar.gz /usr/local/src/liquidsoap/dlcompleted/camomile.tar.gz

Did some checking and found that the version of cppo used by the Centova installer is very, very old. They use cppo-0.9.4.tar.gz . The latest version 1.6.0 and can be found here: https://opam.ocaml.org/packages/cppo/

I have no idea whether it would be possible to use this newer version. Maybe the developers can have a look at it.

Unfortunately this is a requirement for building Liquidsoap, and there isn't much our developers can do about that.

It worked for me. But I do not like centos, and now with debian I have a number of new problems. Issues with liquidsoap and ices.

Currently there are no other known issues that we are aware of. If you are having difficulties setting up Centova Cast under a supported Linux distribution, please open a ticket to our support department and we'll be happy to walk you through troubleshooting those.


Regards.
hi Roger,

Thanks for your help. That worked.
Same problem here.


Processing camomile.tar.gz ...


Autoconfiguring camomile ...

autoconf: error: no input file
Autoconf failed for camomile.tar.gz; aborting

Is there no solution yet?

Thank you Roger,

I'm using CentOS7 with Plesk and the install for liquidsoap worked

Tommy TBones 8)
The Granddaddy of Internet radio for Unknown, Unsigned and Indie Music
Live since March 1999
Tommy TBones
Owner
440MUSIC.COM
Internet Radio & Music Store
The Granddaddy of Internet Radio for
Unknown, Unsigned and Indie Music
Hello,
three days trying to install Centova !!!!

Does anyone have any help with this problem when installing?

We are installing on a completely new server and we always get the same message that it is impossible to install Liquidsoap.

Everything we have on the internet we tried out of options. None of them solve this error.

Please for help !!!

Installing cppo ...

install -m 0755 cppo /usr/local/bin || \
        install -m 0755 cppo.exe /usr/local/bin

Unpacking camomile.tar.gz ...


Processing camomile.tar.gz ...


Autoconfiguring camomile ...

autoconf: error: no input file
Autoconf failed for camomile.tar.gz; aborting
Installer exited with error, aborting