Important! accept multiple IP - allow default settings srcip=ANY dstip=ANY

Read 4833 times
Hi,
sorry for my bad english.

Shoutcast allows for the entry: DestIP=ANY to direct the server to listen on multiple IP address for client  stream requests.  But the matching field in Centova gives an error when ANY is entered; obviously parsing for an IP address. Also, the field is limited to the maximum size for one IP address.

Is there any way to override this restriction?


I need allow multiple IP in shoutcast configuration.

Currently for a shoutcast server can be heard in all directions from my server, I have set it in Centova using "0.0.0.0", works! but station not listed in YP.

Example:
ERROR [YP] Stream #1 connection attempt failed. YP2 error code is 480 [Cannot see your station/computer (URL: http://0.0.0.0:8250/stream) from the Internet, disable Internet Sharing/NAT/firewall/ISP cache.]


We need Centova accept this default setting:


, SrcIP, the interface to listen for source connections on (or to make relay
, Connections on if relaying). Usually Can and will be ANY or 127.0.0.1
, (Making it 127.0.0.1 will keep other machines from being able to
, Your broadcast using shoutcast server)
SrcIP = ANY

, DestIP, IP to listen for clients on (and to contact yp.shoutcast.com)
, Can and will be be ANY Usually. If your machine has multiple IP addresses,
, Set This to the one you want it to be accessed by.
DestIP = ANY



So shoutcast works with localhost (perfect for wowza), and other IP in the server.

Can't make this the default configuration for every new account and you will have to edit manually each station's configuration file, with "expert".  But any change you make to the station's configuration from your Centova Cast control panel will overwrite the changes you've done manually in the configuration file.


Please, vote for this...
Thanks!
Last Edit: March 21, 2014, 03:04:38 pm by solumedia
you're not understanding the purpose of those DNAS config options. they only allow the DNAS to bind on a single IP address and so allow for controlling connections to and from the DNAS (subject to how the machine(s) which it is run on work / allow). when 'multiple IP' are referenced, it means it'll work with any IP address bound to the host machine, not that the DNAS is going to run on multiple IP as specified, hence why Centova and the DNAS only accept a single IP/DNS value for either of the options.

so setting destip=0.0.0.0 will effectively be ignored (allowing the DNAS to run) but as you're seeing (and which i'll need to add to the todo list to fix in a later v2 DNAS build, though i should probably add some additional filtering on the YP side to ignore such values and instead use the IP of the connection it received), the destip setting is being incorrectly seen as valid still and so it will be used in the details sent to the YP server and that is what is causing the 480 error (as the YP will check the address it's being told the DNAS is on is valid and obviously 0.0.0.0 will not work in your instance.
Thank Dro!

Obviously will not work properly with 0.0.0.0. Configuring with 0.0.0.0 I can hear shoutcast from any server IP address (this is what I need). But working partially  (error CentovaCast and shoutcast YP)

I need: can be heard with any IP addresses from my server. Or at least listen with the main IP and localhost.

I use wowza and other applications that take the same shoutcast from different IP on the same server.

What can I do?

Its important for me
Last Edit: March 24, 2014, 09:07:28 pm by solumedia
leave the field empty which is the same as setting 'any' for the value.

alternatively (which i'm not sure about), if you've got a DNS entry setup, you can set that and it will be used instead by the DNAS and is a far better option to go with than relying on an IP for the stream (which makes things easier for you and listeners in the long term).
I don't think CentovaCast allow to leave the field empty.

How can I configure the DNAS? I need to at least be able to connect to localhost and the main server IP. Listen in two IP.

thank you very much