Please help install icecast -KH

Read 14604 times
I was talking about Sam604 it says in the error
root@debian:/usr/src#
My Auto DJ
Orlando, FL USA
Quality SHOUTcast Hosting http://myautodj.com
SHOUTcast Widgets http://shoutcastwidgets.com
I am using Debian... and I agree that script would not work.. I actually got it to work after modification.  I would post later :)
I was talking about Sam604 it says in the error
root@debian:/usr/src#

Ah. Sorry.  :D
PLEASE  NOTE:THIS IS USED ON A DEBIAN SERVER, ALSO USE AT YOUR OWN RISK (But it worked for me :))

Quote
To install Icecast (Any version manually)
cd /usr/src
wget (Any_version).tar.gz
tar -zxvf Any_version.tar.gz
cd Any_version
sudo apt-get install libxml2-dev (May already be install)
sudo apt-get install libxslt1-dev

wget http://downloads.xiph.org/releases/ogg/libogg-1.3.1.tar.gz
tar xf libogg-1.3.1.tar.gz
cd libogg*
./configure
make && make install

wget http://downloads.xiph.org/releases/vorbis/libvorbis-1.3.3.tar.gz
tar xf libvorbis-1.3.3.tar.gz
cd libvorbis*
./configure
make && make install
# ^^ install Ogg Vorbis

 ./configure;make CFLAGS="-D_XOPEN_SOURCE=600" && make install && /usr/local/centovacast/sbin/enable_package ICECAST /usr/local/bin/icecast
Last Edit: February 11, 2014, 02:41:05 pm by sam604
ok so while I believe -KH is indeed installed, when I go to the ADMIN of a new server, I get the following:

Quote
This XML file does not appear to have any style information associated with it. The document tree is shown below.
<icestats>
<admin>icemaster@localhost</admin>
<banned_IPs>0</banned_IPs>
<build>20140211182716</build>
<client_connections>24</client_connections>
<clients>1</clients>
<connections>31</connections>
<file_connections>6</file_connections>
<host>example.com</host>
<listener_connections>3</listener_connections>
<listeners>0</listeners>
<location>Earth</location>
<outgoing_kbitrate>0</outgoing_kbitrate>
<server_id>Icecast 2.3.3-kh8</server_id>
<server_start>11/Feb/2014:18:42:50 -0600</server_start>
<source_client_connections>1</source_client_connections>
<source_relay_connections>0</source_relay_connections>
<source_total_connections>1</source_total_connections>
<sources>0</sources>
<stats>0</stats>
<stats_connections>0</stats_connections>
<stream_kbytes_read>1527</stream_kbytes_read>
<stream_kbytes_sent>283</stream_kbytes_sent>
</icestats>

Is this normal? I'm used to the black administrative page that is shown with 2.3.2.

Thoughts?
Last Edit: February 11, 2014, 04:51:49 pm by kahfluie
To clarify my last message...

When I go to the stats page (icecast -kh), I get the normal stats page.  When I click on Administration on the top, I enter username and password. This is where I get the page that says only that. ( http://ipnumber:port/admin ). However, if I go to the stats.xsl page, it goes back to normal ( http://ip_number:port/admin/stats.xsl ). I believe this page is the Administration home page. 

Is there a redirect or something missing to show this page formatted? Would anyone know how to fix this?

I've attached a couple of screen shots to explain it better. One is what I see when I go to the "Administration" page  ( http://ipnumber:port/admin ). The other is then I go to the stats.xsl ( http://ip_number:port/admin/stats.xsl ).

Any help is greatly appreciated.
In addition to my question above, when I created a new server, shouldn't Icecast 2 AND Icecast -KH be in the drop down, of did I sacrifice Icecast 2 for -KH?

If I wanted to go back, is there a way to do so without hurting anything?