3.x FreeBSD Support

Read 3430 times
I currently run 2.x on a FreeBSD system, and require FreeBSD support to upgrade to 3.x.  I saw that it was mentioned in the release notes that this was going to be completed in the "near future," but I'd really like for that near future to be ASAP.

If you need a test-bed, I can happily provide a FreeBSD 9.0 x64 jail for the Centova team to use, if desired.
Bumping this request.  Still really need this.  PHP 5.3 is going End-of-Life on FreeBSD very soon, and Centova 2.x will not run on PHP 5.4.

Please work on this as soon as possible.
http://docs.freebsd.org/cgi/getmsg.cgi?fetch=3009964+0+/usr/local/www/db/text/2013/svn-ports-all/20130714.svn-ports-all

Quote
Date: Sat Jul 13 15:21:08 2013

  Please Note: This will be the last regular release of the PHP 5.3 series.
  All users of PHP are encouraged to upgrade to PHP 5.4 or PHP 5.5. The PHP
  5.3 series will receive only security fixes for the next year.
 
  I will maintain PHP 5.3 until the first not fixed vulnerability is found.
  At that point I will deprecate the port with a 2 months notice, if no
  other volunteer is found in that time the port will be removed.

Again, Centova 2.x will not run on PHP 5.4 or above.  It is imperative that FreeBSD support be implemented for me to continue using this reliably, as PHP 5.3 is being phased out probably by September.
Again, Centova 2.x will not run on PHP 5.4 or above.
Despite the italics, this is simply not true. :)  PHP 5.4 support was implemented in January (it's explicitly noted in the release changelog), and many of our clients are using PHP 5.4 with Centova Cast v2.2.7 without any problems at all.  I myself am using it on Debian Wheezy's build of PHP 5.4.4 and it works identically to any other PHP version.

As I mentioned in the support ticket you opened, if you are having problems with 5.4, you just need to report the nature of the problem via the helpdesk and we'll be happy to assist with your particular situation... but for virtually everyone else, it just works as-is.