Listeners disconnecting on source change

Read 3429 times
Hello,

I've been having this very annoying problem, but I suppose it is not a bug since nobody seems to talk about it...

Everytime a DJ connects to /live (or disconnects) the players like Audacious or Winamp stop playing or they start buffering or make strange sounds. By stopping and starting the stream in the player the problem goes away, but still... I loose lots of listeners everytime...

In this particular case I use IDJC (on Ubuntu) for live stream and IceCast for server.
The bitrate (64kbps) is set to be the same in the DJ console and for AutoDJ in CentovaCast.

Any ideas?

Thanks!
Everytime a DJ connects to /live (or disconnects) the players like Audacious or Winamp stop playing or they start buffering or make strange sounds. By stopping and starting the stream in the player the problem goes away
This is a classic, textbook description of what happens when you change encoding parameters in the middle of a broadcast. 

The bitrate (64kbps) is set to be the same in the DJ console and for AutoDJ in CentovaCast.
It's not just the bit rate that needs to be identical -- the sample rate and number of channels also need to be precisely the same.  Also ensure that you're not switching from CBR to VBR or vice-versa.  EVERYTHING needs to be identical.

Based on your description my money is on a sample rate mismatch.
Thank you for your answer.

One more question about channels:

In my DJ Console channel settings I have stereo, mono and joint stereo while in CC, for AutoDJ i have stereo and mono.
If I want to use joint stereo (i figured it was better) on the DJ Console, which channel should I chose for CC AutoDJ?

thanks!